Dogecoin blockchain delay

Incident Report for Scorechain status page

Resolved

We have implemented a fix in our Dogecoin block parser. All Dogecoin servers have been fully restored and are up-to-date on the chain.
Posted Feb 27, 2026 - 08:44 UTC

Investigating

The Dogecoin blockchain synchronization is currently blocked. We are currently working on a fix, we'll keep you updated.
Posted Feb 26, 2026 - 23:16 UTC
This incident affected: Scorechain API (API and application).